Designing Anti-Islanding Detection Using the Synchrophasor Vector Processor

A Thesis
Presented to
The Faculty of California Polytechnic State University,
San Luis Obispo

In Partial Fulfillment
Of the Requirements for the Degree
Master of Science in Electrical Engineering

By
Ruth Huang
June, 2013
COMMITTEE MEMBERSHIP

TITLE: Designing Anti-Islanding Detection Using the Synchrophasor Vector Processor

AUTHOR: Ruth Huang

DATE SUBMITTED: June, 2013

COMMITTEE CHAIR: Dr. Ali Shaban, Professor
Electrical Engineering Department

COMMITTEE MEMBER: Dr. Taufik, Professor
Electrical Engineering Department

COMMITTEE MEMBER: Dr. Ahmed Nafisi
Electrical Engineering Department
ABSTRACT

Designing Anti-Islanding Detection Using the Synchrophasor Vector Processor

Ruth Huang

The need for distributed generation (DG) has become more and more popular because of the adverse effects of fossil fuels and the fear of running out of fossil fuels. By having DG, there are less transmission losses, voltage support, controllability of the system, decreased costs in transmission and distribution, power quality improvement, energy efficiency, and reduced reserve margin. The adverse effects of DG are voltage flicker, harmonics, and islanding. Islanding occurs when the DG continues to energize the power system when the main utility is disconnected. Detecting islanding is important for personnel safety, speedy restoration, and equipment protection. This paper describes the different islanding methods currently used and the benefits of combining two passive islanding detection methods, under/over voltage detection and voltage phase jump detection methods, using the synchrophasor vector processor (SVP).
ACKNOWLEDGMENTS

I would like to thank Dr. Ali Shaban for being a great advisor and for all your help and guidance through every step of my thesis. Without you I would not have been able to finish. Thank you for being patient and understanding as we went through our various designs for this thesis.

I would also like to thank Jaime Carmo and Corey Ricketts for all of your help setting up my test bench. Without you two I would not have computers or network and hardware setup help. Thank you for being so timely with all your help; without you I would not have finished on time.

I would like to thank Dr. Taufik and Dr. Ahmed Nafisi for being a part of my committee and answering all my questions that I came with.

I would like to thank Schweitzer Engineering for all the donated equipment and all your technical support. I learned so much using all the up-to-date equipment. Thank you Jeff Otto, Demetrios Tziouvaras, Armando Guzman, and Alejandro Avendano for all the countless emails, voice calls, and conference calls that were made in the last two years.

I would like to thank the EE department for all your support and dragging me through the finish line.

Lastly, I would like to thank my friends and family for all your support. Thank you for encouraging me to never give up and to take things one step at a time. Thank you graduate students for making thesis interesting. I have enjoyed our trouble shooting, writing, and coffee breaks together.
Contents

LIST OF TABLES .................................................................................................................. IX

LIST OF FIGURES .............................................................................................................. X

1 INTRODUCTION .............................................................................................................. 1

1.1 DISTRIBUTED GENERATION .................................................................................. 1

1.2 ISLANDING .............................................................................................................. 1

2 BACKGROUND ............................................................................................................. 4

2.1 PASSIVE ISLANDING DETECTION ......................................................................... 4

2.1.1 Over/Under Voltage ......................................................................................... 4

2.1.2 Over/Under Frequency ...................................................................................... 6

2.1.3 Rate of Change of Frequency (ROCOF) ......................................................... 7

2.1.4 Vector Shift ...................................................................................................... 8

2.1.5 Voltage Phase Jump/Voltage Angle Difference .......................................... 8

2.1.6 Voltage Unbalance and Total Harmonic Distortion .................................. 8

2.2 ACTIVE ISLANDING DETECTION ....................................................................... 9

2.2.1 Impedance Measurements ............................................................................... 9

2.2.2 Detection of Impedance at Specific Frequency .............................................. 10

2.2.3 Slip Mode Frequency Method ....................................................................... 10

2.2.4 Frequency Bias or Active Frequency Drift Method ..................................... 11
2.2.5 Sandia Frequency Shift ................................................................. 12
2.2.6 Sandia Voltage Shift ................................................................. 12
2.2.7 Automatic Phase Shift ................................................................. 13
2.3 COMMUNICATIONS ........................................................................ 14
   2.3.1 Transfer Trip Scheme ................................................................. 14
2.4 MODERN METHODS ........................................................................ 15
2.5 EQUIPMENT BACKGROUND ............................................................ 15
   2.5.1 Synchrophasor Vector Processor ................................................. 15
   2.5.2 GPS Clock, SEL 2407 ................................................................. 17
   2.5.3 SEL 421 .................................................................................. 17
Adaptive Multi-Channel Source (SEL 5401, AMS) ................. 18

3 DESIGN .................................................................................................. 20

3.1 PRELIMINARY DESIGN: .................................................................... 20
   3.1.1 The First Step, detecting a fault using the SEL 421: ................. 23
   3.1.2 The Second Step, Observing Voltage and Current Phasors of the Inverter During Islanding: ................................................................. 34

3.2 FINAL DESIGN: .................................................................................. 35
   3.2.1 Normal Voltage and Current Phasors Calculation .................. 40
   3.2.2 Calculating Voltage Phasors at Station B: ............................. 41
   3.2.3 Current and Voltage phase differences: ............................... 44
   3.2.4 Under/Over Voltage settings: ................................................. 47
   3.2.5 Communication between the SVP and SEL-421 .................... 47
3.2.6 Programming the Voltage Phase Jump and Under/Over Voltage: 68

3.2.7 Programming the GPS Clock: ................................................................. 74

3.2.8 Using the SEL5401 to program test cases: ........................................ 76

3.2.9 Running the Tests: .................................................................................... 80

4 TEST RESULTS............................................................................................. 81

4.1 SETTING 1: 50% OF APPARENT POWER: ........................................ 81

4.2 SETTING 2: 98% OF APPARENT POWER ................................................. 83

4.3 SETTING 3: 82.25% OF APPARENT POWER ........................................... 86

4.4 SETTING 4: 123.38% OF APPARENT POWER .......................................... 89

4.5 SETTING 5: SINGLE PHASE DISTRIBUTED GENERATION .................. 92

5 CONCLUSION: ............................................................................................. 96

6 FUTURE STUDIES: ....................................................................................... 97

6.1 OTHER PASSIVE METHODS: ................................................................. 97

6.2 NEW PASSIVE METHODS: ................................................................. 99

6.3 COST ANALYSIS: .................................................................................... 100

REFERENCES ................................................................................................. 101

APPENDICES .................................................................................................. 103

APPENDIX A: SEL 421 AND SEL 311 LABS ............................................. 104

APPENDIX B: DETECTING INCORRECT INPUT SETTINGS FOR THE AMS... 119
LIST OF TABLES

Table 3-1: Apparent Power, Real Power, Reactive Power, and Voltage for the Different DG settings................................................................. 42
Table 3-2: Voltage Values for Station B before Islanding and for the First 16 cycles of Islanding................................................................. 43
Table 3-3: Voltage and Current Values before Islanding and the First 16 Cycles during Islanding for a single Phase DG........................................ 44
Table 3-4: Phase difference between the Voltage and Current at the PCC for Each DG Setting........................................................................... 45
Table 3-5: GPS Clock Settings .............................................................................................. 75
Table 4-1: Results for DG Setting 1 tests........................................................................ 81
Table 4-2: Results for DG Setting 2 Tests ................................................................. 83
Table 4-3: DG Setting 3 Test Results ............................................................................. 87
Table 4-4: Test Results for DG setting 4................................................................. 89
Table 4-5: DG Setting 5, Having a Single Phase DG, Test Results........... 93
LIST OF FIGURES

Figure 2-1: Simple Power System with Resistive Load........................................ 4
Figure 2-2: Operating Voltage Data to determine Non-Detection Zone .... 5
Figure 2-3: Simple Power System with Resistive and Reactive Load........ 6
Figure 2-4: The Sandia Amplified Frequency Shift, When Slight Change in
Phase Occurs ........................................................................................................ 11
Figure 2-5: Flow Chart (logic) for the Automatic Phase Shift Detection
Method .................................................................................................................. 14
Figure 2-6: Synchrophasor Vector Processor Takes System
Measurements and Logically Determines Output Designations[6]........ 16
Figure 2-7: GPS Clock, SEL 2407[11] ............................................................... 17
Figure 2-8: SEL-421[8] ...................................................................................... 18
Figure 2-9: Figure of AMS, Adaptive Machine Source [9]......................... 19
Figure 3-1: Power System Model for Preliminary Design......................... 20
Figure 3-2: Device Setup for Preliminary Design [8], [7], [6] ..................... 21
Figure 3-3: AcSelerator QuickSet Open Screen ............................................. 23
Figure 3-4: Input Communications Parameters in AcSelerator QuickSet 24
Figure 3-5: Entering Product Identification Number in AcSelerator
QuickSet................................................................................................................ 25
Figure 3-6: Inserting Part Number in AcSelerator QuickSet....................... 26
Figure 3-7: Configuring Global Settings for the SEL 421 Station A......... 27
Figure 3-8: Line Configurations for the SEL 421 at Station A Part 1........ 28
Figure 3-9: Line Configurations for the SEL 421 at Station A Part 2 ....... 28
Figure 3-10: Phase Distance Element Settings .................................. 29
Figure 3-11: Power System Model to Test Fault Detection ..................... 30
Figure 3-12: Directions to Get Event Files ....................................... 31
Figure 3-13: Graph of Current and Voltage during Single Line to Ground Fault Detection ................................................................. 32
Figure 3-14: Graph of Current and Voltage during Phase to Phase Fault Detection .................................................................................... 33
Figure 3-15: Graph of Current and Voltage during Three Phase Fault Detection .......................................................................................... 34
Figure 3-16: Hardware Connection of the AMS, SEL-421, GPS Clock, SVP, and Computer [8], [7], [6], [9] ................................................................. 36
Figure 3-17: Block Diagram of Final Design ........................................... 37
Figure 3-18: The Final Design of the Test Circuit having a Resistive and Reactive Load ....................................................................................... 38
Figure 3-19: Synchrophasor Settings for Station A Part 1 ....................... 48
Figure 3-20: Synchrophasor Settings for Station A Part 2 ....................... 48
Figure 3-21: Global Settings for Station B .............................................. 49
Figure 3-22: Synchrophasor Settings for Station B .................................. 50
Figure 3-23: Directions From the SVP Manual to Program the TCS POU [12] .............................................................................................. 52
Figure 3-24: Variables Used for the TCS POU ........................................ 52
Figure 3-25: Program Logic for the TCS POU ........................................ 54
Figure 3-26: Communication Parameter Settings ........................................ 55
Figure 3-27: Steps in the SVP Instructions Manual to create a new PMU
[12] ....................................................................................................................... 56
Figure 3-28: How to Program the PMCU using Functional Blocks from the
SVP Instructions Manual [12] ........................................................................... 56
Figure 3-29: How to add a new network using the FBD type POU ............ 57
Figure 3-30: PMCU POU Finished Product .................................................... 58
Figure 3-31: How to Append a Task using Task Configuration ................. 59
Figure 3-32: Variables for the PMCU out POU ............................................. 60
Figure 3-33: How to Start PDC Assistant ...................................................... 63
Figure 3-34: Adding the SVP to the PDC Assistant ..................................... 64
Figure 3-35: How to Connect to the PDC using the PDC Assistant .......... 65
Figure 3-36: Collecting Data from the SVP using a Continuous Archive . 66
Figure 3-37: Setting of where the Archived Data will go and How it is
Formatted ........................................................................................................... 67
Figure 3-38: Exporting the Archived Data Using the PDC Assistant ......... 68
Figure 3-39: POU that Sends a Bit to RB01 .................................................... 71
Figure 3-40: Trip Logic in the SEL 421 Station B ........................................ 72
Figure 3-41: Connecting the AMS to the SEL 421 ....................................... 77
Figure 3-42: Choosing Which Type of Relay to Configure ...................... 78
Figure 3-43: State 1 of the AMS Test ............................................................ 79
Figure 3-44: Adding another State to the Test ............................................ 79
Figure 3-45: Downloading and Running the Test Case ......................... 80
Figure 4-1: Phase A Voltage and Current during Islanding using Under/Over Voltage Detection Method for Setting 1 .......................... 82
Figure 4-2 Phase A Voltage and Current during Islanding using Voltage Phase Jump Detection Method for Setting 2 ........................................... 84
Figure 4-3: Normal Phase Difference Angles (75 degrees) ................... 85
Figure 4-4: Phase Difference at 0.5 cycles is 70 degrees ....................... 85
Figure 4-5: Phase Difference at 4 cycles is 65 degrees ......................... 86
Figure 4-6: Phase A Voltage and Current during Islanding using Voltage Phase Jump Detection Method for Setting 3 .......................... 88
Figure 4-7: DG Setting 3 Phase Difference at 5 Cycles After Islanding ... 88
Figure 4-8 Phase A Voltage and Current during Islanding using Over/Under Voltage Detection Method for Setting 4 ......................... 90
Figure 4-9: Phase A Voltage and Current during Islanding using Voltage Phase Jump Detection Method for Setting 4 ..................... 91
Figure 4-10: Phase A and B Voltage and Phase A Current during Islanding using Over/Under Voltage Detection Method for Setting 5 .................. 94
Figure 0-1: Where to connect the Voltage Readings .......................... 107
Figure 0-2: 3 Phase Breakers Attached to Out 105 to ............................. 108
Figure 0-3: Output Current from the Current Transformers are Connected in the Iw section ................................................................. 109
Figure 0-4: First Screen When Opening AcSelerator QuickSet ............ 112
Figure 0-5: Inputting Part Number into AcSelerator QuickSet .............. 113
Figure 0-6: Inputting Phase Distance Settings .................................... 113
Figure 0-7: Trip Settings set to Phase and Ground Zone 1 Detection ... 114

Figure 0-8: Out105 Connected to the 3 Phase Circuit Breaker Trips when Trip is Alarmed................................................................. 115

Figure 0-9: General Settings for the SEL 311 ...................................... 115

Figure 0-10: Communicating to the SEL 311 using the terminal......... 117

Figure 0-11: DG Setting 1 Voltage and Current when the Phase B and C Voltage are Switched for the First 8 Cycles of Islanding............... 120
1 Introduction

1.1 Distributed Generation

The need for distributed generation (DG) has become more and more popular because of the adverse effects of fossil fuels and the fear of running out of fossil fuels. DG has the ability to adopt different sources of energy such as solar, wind, methane, fuel cells, gas turbines, and combustion engines. By having DG, the source is closer to the load and therefore will have fewer losses, provide voltage support, and have more controllability of the system. The demand for power has increased each year; therefore, the cost of transmission and distribution will also increase. A utility can improve power quality, energy efficiency, and cost by optimizing the use of DG systems. Having DG in the power system provides local generation to the load and can reduce the reserve margin needed in a utility. [1], [4], [2]

Although DG has the above qualities, it does not come without any drawbacks. With the DG there could be noticeable voltage flicker, harmonics, short circuit values, and islanding. This thesis will focus on islanding. [4]

1.2 Islanding

“Islanding occurs when the distributed generator continues to energize a portion of the utility system that has been separated from the main utility system (grid).” [4] Islanding can be harmful for the following reasons. Firstly, network
personnel and foremen safety may be compromised. They may assume a line is
death when it is not and working on an energized line can lead to injury or death.
Foremen and network personnel need to wait and ensure the line is de-
energized, making larger delays for restoration. Secondly, the DG can lead to
failing auto-reclosing. Since the line is still energized, there will be voltage at the
fault site and an arc will occur at the fault point. Thirdly, with only the DG
energizing the line, the power quality is compromised and may damage
equipment and loads that were designed to work only in certain power quality
circumstances. Fourthly, when islanding, the phase, frequency, and voltage may
change when reclosing occurs; it will close out-of-step and may cause damage
and stress to the DG and the circuit breaker. [1]

As previously stated, there are many consequences of islanding; hence,
there are many detection methods to properly monitor the system. By observing
how DG acts under normal and abnormal conditions, different detection methods
have been implemented. There are three different categories for island detection:
passive, active, and communications. Passive island detection entails measuring
different electrical values, such as voltage and current magnitude and phase, and
processing them to recognize the formation of islanding. [1] Active detection uses
a disturbance signal that is applied to a parameter of the DG to detect islanding.
The active method causes one of the DG parameters to exceed one of the
passive method detection settings. [2] Active detection is based on making
continuous small changes at the point of common coupling and analyzing the
response to determine islanding. [1] Communications method uses information from the power system to detect islanding. For example, when islanding, a circuit breaker usually needs to open; with that information, islanding can be detected.

[1]

In this thesis, chapter two describes the different kinds of passive, active and communications detection methods that are currently used in industry. Chapter three describes the design process of the test to detect islanding using the SVP. Chapter four presents and analyzes the results from testing: that it is better to use multiple detection methods rather than one, and chapter five ends with some closing remarks. In chapter six, future studies and theses are discussed.
2 Background

2.1 Passive Islanding Detection

2.1.1 Over/Under Voltage

Under and over voltage can be detected when there is a change in complex power at the point of common coupling (PCC), CB1. [2] For example, a simple power system is shown below in Figure 2-1 with an infinite bus, a DG, and a load.

![Simple Power System with Resistive Load](image)

**Figure 2-1:** Simple Power System with Resistive Load

In the power system, the generator can supply 10kW of the load; the other 90kW is supplied by the infinite bus. This means that,

\[
\Delta P = P_{\text{Load}} - P_{\text{gen1}} = 100kW - 10kW = 90kW. \quad 2-1
\]

The change in power correlates to a change in voltage when CB1 opens and an island is formed. In the first cycles of islanding, the inductance will impede instantaneous current change. However, Gen 1 can only supply 10kW. The voltage will have to decrease unless load is shed. In this case,
\[ I_{load} = \frac{P_{load}}{\sqrt{3}V_{load}} = \frac{100\text{kW}}{\sqrt{3} \cdot 208\text{V}} = 277.572\text{A}. \quad 2-2 \]

When CB1 opens,

\[ V_{load} = \frac{P_{Gen1}}{\sqrt{3}I_{load}} = \frac{10\text{kW}}{\sqrt{3} \cdot 277.572\text{A}} = 20.8\text{V}. \quad 2-3 \]

This means that there is an under voltage. On the other hand, if Gen1 could supply 1000kW then there would be an overvoltage of [2]

\[ V_{load} = \frac{P_{Gen1}}{\sqrt{3}I_{load}} = \frac{1000\text{kW}}{\sqrt{3} \cdot 277.572\text{A}} = 2080\text{V} \quad 2-4 \]

To determine islanding, the change in voltage is compared to a predetermined cut off voltage. By looking at normal operating data, a non-detection zone can be determined. For less stable systems the non-detection zone will be larger. An example is shown in Figure 2-2 below.

Figure 2-2: Operating Voltage Data to determine Non-Detection Zone
2.1.2 Over/Under Frequency

Under and over frequency can be detected when there is a change in the reactive power at the point of common coupling, CB1. [2] When there is a change in Q this means that the power factor will have to change. For simplicity, the assumption that there is only displacement power factor and no distortion power factor in this system will be made. For example, Figure 2-3 below has a simple power system with an infinite bus, a load of (75 + j75) kVA, and a generator, Gen1, that can supply (75 + j50) kVA. This means that there is a

\[ \Delta Q = Q_{Load} - Q_{Gen1} = 75kVAR - 50kVAR = 25kVAR. \]  \[2-5\]

Under normal conditions,

\[ I_{Load} = \frac{S}{\sqrt{3}} = \frac{106.066kVA}{208\sqrt{3}} = 294.409A \]  \[2-6\]

With an angle difference of

\[ \theta = \tan^{-1}\left(\frac{Q}{P}\right) = \tan^{-1}\left(\frac{75kVAR}{75kW}\right) = 45^\circ. \]  \[2-7\]

Figure 2-3 Simple Power System with Resistive and Reactive Load
When islanding occurs,

\[ V_{load} = \frac{S_{Gen1}}{I_{Load} \sqrt{3}} = \frac{90.138 < 33.69 kVA}{294.409 < 45 \sqrt{3}} = 176.767 \angle -11.31^\circ \] \hspace{1cm} 2-8

Where the angle difference between the current and voltage at the load is

\[ \theta = -11.31^\circ - (-45^\circ) = 33.69^\circ. \] \hspace{1cm} 2-9

If the change in phase angle happens in 2 cycles, the phase changes linearly, and measurements are taken every 2 cycles then

\[ \Delta \theta_{V_{load}}(t) = \Delta \omega(t) \times \Delta t, \] \hspace{1cm} 2-10

Therefore,

\[ \Delta f_{V_{load}} = \frac{\Delta \theta}{2\pi \Delta t} = \frac{(-11.31^\circ - 0^\circ) \times (\pi \text{rad} / 180^\circ)}{\frac{2}{60Hz} \times 2\pi} = -0.943 \text{Hz}. \] \hspace{1cm} 2-11

The difference is negative. This means that there is an under frequency of 59.057Hz. The frequency change is compared to a predetermined cut off setting to determine islanding.

### 2.1.3 Rate of Change of Frequency (ROCOF)

The rate of change of frequency is similar to the under/over frequency detection. The difference lies in detecting the rate at which frequency changes instead of the difference between the actual frequency and normal frequency. Usual ROCOF cut off settings range from 0.1Hz/s to 1.2Hz/s with detection times between 0.2 seconds and 0.5 seconds. [1]
2.1.4 Vector Shift

Vector shift is also similar to under/over frequency detection. Instead of having a set initial value to compare the new frequency to the normal frequency, the new frequency is compared to the previously calculated frequency. This method is faster than the under/over frequency method; islanding can be determined in as little as one cycle. [1]

2.1.5 Voltage Phase Jump/Voltage Angle Difference

For a current sourced inverter, voltage phase jump detection is determined by measuring the phase difference of the voltage at the point of common coupling and the current through the load. For a voltage sourced inverter, the phase jump detection is determined by measuring the phase difference between the current at the point of common coupling and the voltage at the inverter. [2]

It can also be observed that the difference between the voltage phase and current phase at the point of common coupling changes when islanding occurs. This can also be used to determine islanding and can only be used if the load is not purely resistive, which is true in most cases.

2.1.6 Voltage Unbalance and Total Harmonic Distortion

When islanding occurs, voltage swings occur and there will be voltage unbalance change. Voltage unbalanced (VU) is calculated by the ratio of the negative sequence over the positive sequence.
Because of the voltage swings, there will also be an increased amount of harmonics in the current; the total harmonic distortion can be calculated and used to determine if islanding is occurring. Total harmonic distortion is calculated by taking the geometric sum of the root mean squared (RMS) current of each harmonic component and dividing it by the fundamental RMS current. [2]

\[ THD = \frac{\sqrt{\sum_{h=2}^{H} I_h^2}}{I_1} \] 2-13

2.2 Active Islanding Detection

The following active islanding detection methods are geared toward photovoltaic systems.

2.2.1 Impedance Measurements

Impedance measurement is used to detect islanding for a single inverter photovoltaic system. The output current of the inverter is

\[ i_{pv} = I_{pv} \sin(\omega_{pv} t + \phi_{pv}) \] 2-14

Where \( I_{pv} \) is the magnitude of the inverter’s output current, \( \omega_{pv} \) is the angular frequency of the inverter’s output current, and \( \phi_{pv} \) is the phase shift of the inverter’s current with respect to the reference angle. A change in \( I_{pv}, \omega_{pv}, \) or \( \phi_{pv} \) can be imposed onto the PV system. When the utility is disconnected, the small change in power can be detected at the point of common coupling. This method
is called impedance measurements because the inverter measures the change in voltage over the change in current. [2]

2.2.2 Detection of Impedance at Specific Frequency

In the detection of impedance at specific frequency method, harmonic currents at specific frequencies are injected into the system. During normal conditions the impedance of the system is less than the impedance of the load at these specific harmonic frequencies. This means that the harmonic currents will not flow through the load. However, when the system is disconnected, the harmonic current will flow through the load (path of least resistance); harmonic voltages observed will be proportional to the load impedance at that frequency. Islanding can be assumed when the harmonic voltages are observed. [2]

2.2.3 Slip Mode Frequency Method

The current through the inverter of the DG is

\[ i_{pv} = I_{pv} \sin(\omega_{pv} t + \phi_{pv}). \]  

The slip mode frequency method uses positive feedback; the controller for the inverter uses the S-shaped phase response curve on \( \phi_{pv} \) to detect islanding. When the DG is connected, the utility will provide a stable operating point. However, the phase response is set such that if operating frequency is not equal to utility frequency, the frequency will be unstable. When the utility disconnects, a slight change in the frequency occurs unless the DG supplies can supply the load perfectly. When the slight change occurs, the response to the phase response
amplifies the change in phase until it reaches one of two predetermined points. The predetermined points are chosen such that the over/under frequency detection will be triggered and islanding is detected. The following example from Sandia in Figure 2-4 shows the predetermined points at A and C. In normal conditions, when the DG is connected to the utility, the inverter operates at point B. [5]

![Diagram of phase response vs. frequency](image)

**Figure 2-4: The Sandia Amplified Frequency Shift, When Slight Change in Phase Occurs**

### 2.2.4 Frequency Bias or Active Frequency Drift Method

The frequency bias method is used when there is a microprocessor based controller for the inverter on the PV system. In this method, a distorted current waveform is injected to the system through the inverter. The current waveform
will have a zero current dead time. When the PV system is connected to the utility, the output voltage waveform will follow that of the utility. However, when the PV system is disconnected from the utility, the output voltage will follow the current waveform; since the current has a zero current dead time, the zero crossing of the output voltage will occur sooner than if the utility was connected, increasing the voltage frequency. The outcome of the sooner voltage zero crossing, is a sooner current zero crossing, making the current frequency increase. This will cause a cyclic effect where the faster zero crossing of voltage will cause a faster zero crossing of current and vice versa. This cycle will continue until the frequency passes the threshold for over/under frequency and islanding is detected. [5]

2.2.5 Sandia Frequency Shift

The Sandia frequency shift method is a variation of the frequency bias method. A positive feedback loop is implemented on the frequency of the inverter. When connected to the utility, the stability of the utility inhibits a change in frequency. However, when the utility is disconnected the frequency will shift until it passes the over/under frequency threshold and islanding is detected. [5]

2.2.6 Sandia Voltage Shift

The Sandia voltage shift method uses a positive feedback loop for the output voltage of an inverter. When the voltage changes to be smaller or larger than the nominal RMS value, the output current of the inverter is increased or decreased, respectively. If the PV system is connected to the utility, the slight
change in current from the PV system will not affect the output voltage. If the PV system was disconnected from the utility, a cyclic effect will take place, where the decrease in current will cause a decrease in voltage; the cycle will continue until the under voltage threshold is reached. Conversely, if there is an increase in current, because of a slight voltage increase in the system, there will be an increase in voltage, which will cause an increase in current until overvoltage threshold is reached. [5]

2.2.7 Automatic Phase Shift

Because the frequency bias method and the slip mode frequency shift method do not work for certain RLC loads, the automatic phase shift method can be implemented. This method uses the algorithm, shown in Figure 2-5, to determine $\phi_{PV}$, which will affect the frequency. If islanding is occurring, under or over frequency threshold will be crossed. [2]
2.3 Communications

2.3.1 Transfer Trip Scheme

Islanding can be detected by monitoring the status of the circuit breaker near the point of common coupling. Most utilities use Supervisory Control And Data Acquisition (SCADA) systems to collect circuit breakers data; this data can be used to determine if a circuit breaker has tripped and therefore determine if islanding has occurred. Information about islanding and circuit breaker status can also be communicated through power lines; by broadcasting a signal at a higher frequency to the CB that connects the DG to the system, protective precautions can be taken to open that CB. [5]
2.4 Modern Methods

Generally speaking, passive islanding detection is cheaper but less accurate and slower due to a larger non-detection zone, whereas active detection methods have smaller non-detection zones but are costly and deteriorate the power quality. Communications detection can be costly, and the reliability depends on the reliability of the communications system already intact. Newer technologies for passive detection have decreased the time it takes to detect islanding and can be combined together onto one device. The Synchrophasor Vector Processor (SVP) is a device that can perform many passive detection methods.

2.5 Equipment Background

2.5.1 Synchrophasor Vector Processor

The Synchrophasor Vector Processor (SVP) is a powerful device that can identify different system conditions using different voltage, current, phase, real power, and reactive power measurements from phasor measurement units (PMUs). The system has preconfigured functional blocks in the SVP Configurator, a program to configure the SVP, that are commonly used in utilities. If there is a new mathematical analysis that needs to be computed, a functional block may be coded in Codesys. The SVP can also be used to control circuit breakers, static VAR controls, and generators to improve system efficiency by looking at loop flow, optimizing voltages, and balancing loads. [6] The data that the SVP collects can be sent to the Phasor Data Concentrator (PDC / SEL 5073)
to convert the data into a readable form, which can be viewed and analyzed. Figure 2-6 below shows a picture of the SVP and its high level function. [6]

![Synchrophasor Vector Processor Diagram](image)

**Figure 2-6: Synchrophasor Vector Processor Takes System Measurements and Logically Determines Output Designations [6]**
2.5.2 GPS Clock, SEL 2407

The GPS clock, shown in Figure 2-7, will be connected to the SEL 421 and the SVP and will time stamp every measurement the SEL 421 records. It has an accuracy of ±100ns. The SEL 2407 has an antenna that needs to be set up in a place where it has 360˚ of no obstruction in order to get a good signal. When there is a good signal, the satellite lock LED will illuminate; when there is no signal, the holdover LED will illuminate. The GPS clock is connected with a BNC-BNC cable to the SEL 421 and the SVP; different formats need to be set for the SEL421 and SVP. [7]

2.5.3 SEL 421

The SEL 421, as shown in Figure 2-8, is a comprehensive relay, which can be used as an overcurrent relay, over/under voltage relay, over/under frequency relay, directional relay, and many others. The SEL 421 can also be used as a PMU, taking synchrophasor measurements, to control two different breakers, and to communicate both serially and over Ethernet. The relay has a
built in web server and has high accuracy time stamping, within 10μs. In this thesis, the SEL 421 will be used to send voltage and current measurements to the synchrophasor vector processor to help determine if islanding has occurred. The SEL421 is configured with the AcSELerator QuickSet software, and events can be viewed using the AcSELerator Analytic Assistant. [8]

Figure 2-8: SEL-421[8]

2.5.4 Adaptive Multi-Channel Source (SEL 5401, AMS)

The AMS, as shown in Figure 2-9, is a test system used to test protective relays. The AMS has the capability to simulate waveforms of current and voltage with a 16bit resolution. The AMS has 6 inputs and 10 outputs, which can be used during testing. For example, one input can be the relay trip signal; if the trip signal is enabled, then the AMS can change states. A test case can be made using the SEL 5401 software, where there can be up to 256 states; a state can change either by the time constraint or when a monitored input signal has changed. Test results can also be viewed and analyzed in the SEL 5401. In this
thesis, the AMS will be used to send voltage and current signals to the SEL 421 to simulate pre and post islanding conditions. [9]

Figure 2-9: Figure of AMS, Adaptive Machine Source [9]
3 Design

3.1 Preliminary Design:

The purpose of this thesis research is to implement and design a reliable islanding detection system using the Synchrophasor Vector Processor (SVP). The SVP is a programmable logic controller that collects and time aligns voltage and current measurement inputs from Phasor Measurement Units (PMUs) and outputs control signals to the connected devices. The original design to test the islanding detection system was to build a power system in the lab by modeling a transmission line using two 10Ω resistors and two 40mH inductors per phase, connecting a 25Ω Y-connected load and adding a PV system to feed the A phase load as shown in Figure 3-1 below.

![Figure 3-1: Power System Model for Preliminary Design](image)
The SEL 421s are serially connected to the SVP, and the SVP and the two SEL 421s are connected to a GPS clock, using a BNC-BNC cable to ensure time aligned data as show in the Figure 3-2 below.

![Figure 3-2: Device Setup for Preliminary Design][8], [7], [6]

Because the PV panels need to be connected to an inverter to supply an alternating current (AC) load, the Enphase inverter was used.

The test consisted of creating a fault using the fault box, which would cause the three pole circuit breaker to trip open. The Photovoltaic (PV) system would then island and supply power to the load. The voltage and current measurements from the two SEL 421s would help the SVP determine if islanding has occurred. The SEL-421 was chosen because of its PMU capabilities. If islanding occurs and was detected, a trip signal would be sent to RB01 to the SEL 421-2, and the trip light will illuminate. The islanding detection process would be timed to ensure that it followed IEEE 1547 standard of 5 seconds. [10]
The SVP would be programmed to test the different passive islanding detection methods mentioned in the background: under/over voltage, under/over frequency, rate of change of frequency, and voltage phase jump. The SVP has the capability to combine different detection methods to ensure detection reliability. For example, consider a case where there is a power system that operates at 80% to 120% nominal voltage and only under/over voltage detection method was used. The detection method was set to detect only when the voltage will fall under 80% nominal voltage or over 120% nominal voltage. If an islanding condition occurs where the voltage does not fall below 80% nominal voltage or over 120% of nominal voltage, but the frequency changes, then the under/over voltage detection method would not detect islanding. However, if the SVP was programmed to send an RB01 signal to the SEL421 for under/over voltage and under/over frequency, then islanding will be detected for the case considered.

The first step to implement this test was to program the SEL-421-1 to take measurements from the model power system and determine if a fault has occurred and trip the circuit breaker. The second step was to test the inverter’s characteristics before and after islanding. Thirdly, SEL 421-2 needed to be programmed to trip when a remote bit was sent to it. Fourthly, the two SEL-421s and the SVP needed to be programmed to communicate with one another. Fifthly, the SVP needed to be programmed to detect islanding. Lastly, the whole circuit in Figure 3-1 needed to be built and tested to determine if each combination of detection methods would follow the IEEE 1547 standard.
3.1.1 The First Step, detecting a fault using the SEL 421:

To program the SEL-421, AcSelerator Quickset was used. The following steps explain how to program the SEL-421 to detect a fault at 50% of the line.

Step 1.

Open the AcSelerator QuickSet as shown below in Figure 3-3:

![Figure 3-3: AcSelerator QuickSet Open Screen](image)

Step 2.
Under Setup, go to Communications and fill out the information that matches the SEL 421 then press ok to connect. An example is shown below in Figure 3-4.

Note: to view the communications information on the SEL 421 press Esc until you get to the main screen, then press Ent. to get to the main menu, use the arrows to get to Set/Show, then go to Ports and choose the correct port that the serial cable is connected to.

Note: To confirm connection, the bottom left hand corner should say “connected”

Figure 3-4: Input Communications Parameters in AcSelerator

QuickSet
Step 3.

The SEL421 is now connected to the computer. Select New and fill out the appropriate information for your SEL421 as shown below in Figure 3-5.

Note: To view configuration information on the SEL 421, go to the main menu and select View Configuration.

Figure 3-5: Entering Product Identification Number in AcSelerator

QuickSet

Step 4.
After pressing ok the AcSelerator will ask for the part number, fill out the information for the SEL421 being used. An example is shown below in Figure 3-6.

Note: The part number can be found in the same place as in Step 3.

\[\text{Figure 3-6: Inserting Part Number in AcSelerator QuickSet}\]

Step 5.

Set the global general settings as shown below in Figure 3-7.
Figure 3-7: Configuring Global Settings for the SEL 421 Station A

Step 6.

Go to Group 1 → Set 1 → Line Configuration tab and set up the test transmission line. The following example in Figure 3-8 and Figure 3-9 is for a line that is modeled with two 10Ω resistors and two 40mH inductors with a line length of 100 miles with 1:1 transformers connected to the relay.
Figure 3-8: Line Configurations for the SEL 421 at Station A Part 1

Figure 3-9: Line Configurations for the SEL 421 at Station A Part 2
Step 7.

Go to Relay configuration and fill in the following information for the different fault detection methods. The SEL 421 is used as a Distance relay that will detect a fault at 50% of the line.

- E21P (Number of zones) = 1
- Z1P (Zone 1 impedance) = 28.95
- Z1PD (Zone 1 time delay) = 0

**Ground Distance Element** (Same as Phase Distance Element)

- Phase Inst. O/C: E50P (N)
- Time Overcurrent: E51S (N)
- Directional: E32 (AUTO)
- ORDER (QV)
- Reclosing: E79 (N)
- EMANCL (N)
- **Trip Scheme**: ECOMM (N)

Check that the Trip Logic (TR SELOGIC) = M1P OR Z1G

Figure 3-10 below will help show how to set the distance elements for Zone 1.
Step 8.

Save and send these relay settings to the SEL 421.

*Note: To send the file: Select File > Send to transmit the settings to the relay.*

Step 9.

Using the following Figure 3-11 circuit, test the SEL 421 to see if it would detect a fault at 50% of the line.

![Figure 3-11: Power System Model to Test Fault Detection](image)

*Note: switch the B and C when connecting to the grid because it is ACB*

Step 10.

To get events off of the SEL 421, use the AcSelerator Quickset go to Tools→Events→Get Event Files. The Event History Window will pop up. Select the event to view and press Get Selected Event on the right. An example is shown if Figure 3-12.
Figure 3-12: Directions to Get Event Files
The results for-phase-A to ground fault are shown below in Figure 3-13.

Figure 3-13: Graph of Current and Voltage during Single Line to Ground Fault Detection
The results for a Phase to Phase fault are shown below in Figure 3-14.

**Figure 3-14: Graph of Current and Voltage during Phase to Phase Fault Detection**
The results for a three phase fault are shown below in Figure 3-15.

A lab is written for SEL-421 and SEL-311 as shown in Appendix A.

3.1.2 The Second Step, Observing Voltage and Current Phasors of the Inverter During Islanding:

An Enphase M175 inverter was first chosen to be used in the test circuit but was broken, so an Enphase M215 was used instead. Because the Enphase M215 needs a reference AC voltage in order to output power, when the 3-Pole circuit breaker opens, the inverter will no longer have a reference and will automatically turn off. In order to “trick” the inverter into conducting after the CB...
breaks open, another voltage source was going to be used as a reference source. Unfortunately, the other single phase source was 30° out of phase with the A phase of the 3 phase voltage source. Another thought was to connect the inverter directly to the A phase of the 3 phase voltage source, but the voltage drop between the reference voltage and the source would have to be identical to the voltage drop across the line. Because none of the inductors or resistors perfectly match, it was decided that this method of testing would not be plausible.

3.2 Final Design:

The Adaptive Multi-Channel Source (AMS) is usually used to test relay settings for fault detection. It can be programmed to simulate fault situations by sending the relay voltage and current signals it should be reading. Instead of using resistors and inductors to model a power system, the AMS can be used to model the power system. This way more than one scenario can be tested. Each SEL-421 can be connected to an AMS will send current and voltage information to the SEL-421s. That information can be then sent from the SEL-421 to the SVP. The two SEL-421s and the SVP will still be connected to the GPS clock to ensure an accurate timestamp. Figure 3-16 below shows how the hardware is connected. Each AMS is connected to the SEL 421 by a C724 cable. Each AMS is connected to a separate computer serially to download a test file from the SEL 5401. The SVP is connected to each SEL 421 serially. The GPS clock is connected to each 421 and SVP by a BNC-BNC cable. The SVP is connected to
the computer through an Ethernet cable. The Ethernet cables are connected to a switch so that both computers can have internet.

Figure 3-16: Hardware Connection of the AMS, SEL-421, GPS Clock, SVP, and Computer [8], [7], [6], [9]
Figure 3-17: Block Diagram of Final Design [6], [7], [8], [9]

Figure 3-17 above is a block diagram of the final design. It shows how each piece of equipment communicates with each other.

The test consisted of creating a fault which would cause the three pole circuit breaker (CB1) to trip open and the distributed generation (DG) system will island and supply power to the load. The voltage and current measurements from the two SEL 421s would help the SVP logically determine if islanding has
occurred. The SEL-421 was chosen because of its PMU and Synchrophasor capabilities. If islanding has occurred, then a trip signal would be sent to RB01 to the SEL 421 at station B and the trip light will illuminate. In reality, CB-2 would be connected to the SEL 421 in station B to trip open when islanding is detected. The islanding detection time would be timed to ensure that it following IEEE 1547 standard of five seconds. The Figure 3-18 below summarizes a single phase of the three phase Y-connected system that is modeled with the AMS. CB2 does not exist in the circuit that is actually tested, but the trip light on the SEL-421 at Station B will illuminate when islanding is detecting.

![Diagram](image)

**Figure 3-18: The Final Design of the Test Circuit having a Resistive and Reactive Load**

The SVP can be programmed to use different islanding detection methods. In this test Under/Over Voltage and Voltage Phase Jump detection will be used. The following assumptions are made in running this test:
1. In normal conditions, the voltage will vary +/- 20% of nominal voltage.
2. The frequency of the system is 60Hz
3. The load will not shed even if voltage goes under 80% of nominal voltage (the load will draw a constant current) for the first 16 cycles of islanding then load will start to shed.
4. The voltage phase and magnitude is modeled to change in 4 equal steps each lasting 4 cycles.
5. The DG can only act in the 4 different settings described below in Table 3-1

Note: the phase and magnitudes where chosen to be 4 cycles long because the AMS could not handle changing voltage and current measurements faster without giving an error.

The first step to implement this test was to calculate normal voltage and current phasors for both Station A and Station B. The second step was to calculate the voltage magnitude and phase values for station B during islanding conditions for each Distributed Generation (DG) setting. Thirdly, the phase difference between current and voltage were calculated for each DG setting and a detection values were chosen for the SVP for Voltage Phase Jump detection method. Fourthly, the under/over voltage values detection values were determined. Fifthly, the SEL 421s and the SVP needed to be programmed to communicate with one another. Sixthly, the SVP logic needed to be programmed. Seventhly, the GPS clock needed to be programmed and connected to the SVP and SEL 421s. Eighthly, the test cases for the AMS needed to be programmed using the SEL5401. Lastly, each test case needed to be run five times to ensure results.
3.2.1 Normal Voltage and Current Phasors Calculation

During normal conditions:

\[ V_{\text{Grid}L-N} = 120 < 0^\circ V \quad 3-1 \]

This makes:

\[ V_{\text{Grid}L-L} = 208 < 30^\circ V. \quad 3-2 \]

\( V_{\text{Grid}} \) is the voltage that is measured at Station A. When islanding occurs the voltage will remain the same.

Because the system is operating at 60Hz, the line impedance \( Z_{\text{line}} \) is:

\[ Z_{\text{line}} = 20 \text{m} \Omega + 2\pi 60 \times 80 \mu \text{H} = (20 + j30.159) \text{m} \Omega. \quad 3-3 \]

From that, the line current can be calculated,

\[ I_{\text{Line}} = \frac{V_{\text{phase}}}{Z_{\text{Line}} + Z_{\text{Load}}} = \frac{120V}{(20+j30.159)\text{m} \Omega + (10+j10)\Omega} = 8.464 < -45.029A \quad 3-4 \]

Next, the voltage at the load, which is also the voltage of the DG, can be calculated by the following equation:

\[ V_{\text{out}} = V_{\text{Grid}-n} - I_{\text{Line}} * Z_{\text{line}} = \]

\[ 120 < 0^\circ - 8.464 < -45.029A \times (20 + j30.159)\text{m} \Omega = \]

\[ 119.6998 < -0.02903^\circ V. \quad 3-5 \]

The 3\( \phi \) complex power at the load is given by:
\[ S_{3\Phi} = 3 \cdot V_{\text{phase}} \cdot I_{\text{phase}}^* = \]

\[ 3 \cdot 119.6998 < -0.02903^\circ \cdot 8.464 < 45.029A = \]

\[ 3.0394 < 45 \text{ kVA}. \]

3.2.2 Calculating Voltage Phasors at Station B:

The four DG settings are 50\%, 98\%, 82.25\%, and 123.38\% of the load’s apparent power.

Table 3-1 below summarizes the P and Q powers that the DG would provide in each case. Assumption 3 states that the current will stay constant for the first 16 cycles while the voltage adjusts to only having the DG after islanding occurs, therefore the voltage for cycles 13-16 can be calculated to be the following:

\[ V_{L-N50\%} = \frac{S_{3\Phi}}{3 \cdot I_{\text{Line}}} = \frac{1.5197<45\text{kVA}}{3 \cdot 8.464<-45.029A} = 59.849 < -0.02903V_{L-N} \] 3-7

\[ V_{L-N98\%} = \frac{S_{3\Phi}}{3 \cdot I_{\text{Line}}} = \frac{2.976<25\text{kVA}}{3 \cdot 8.464<-45.029A} = 117.2 < -20.02V_{L-N} \] 3-8

\[ V_{L-N82.25\%} = \frac{S_{3\Phi}}{3 \cdot I_{\text{Line}}} = \frac{2.5<36.87 \text{ kVA}}{3 \cdot 8.464<-45.029A} = 98.456 < -8.15V_{L-N} \] 3-9

Page 41
The voltage and phase are modeled to change every 4 cycles linearly, as a result, the following Table 3-2 summarizes the voltage and phase change.

\[
V_{L-N} = \frac{S_{3φ}}{3 \cdot I_{line}} = \frac{3.75 < .963 \text{kVA}}{3 \cdot 8.464 < -45.029 \text{A}} = 147.68 < -44.07 V_{L-N}
\]

**Table 3-1: Apparent Power, Real Power, Reactive Power, and Voltage for the Different DG settings**

<table>
<thead>
<tr>
<th>Setting (% Apparent power of load)</th>
<th>( S_{3φ} ) (kVA)</th>
<th>( P ) (kW)</th>
<th>( Q ) (kVAR)</th>
<th>( V_{L-N} ) (V)</th>
<th>( V_{L-L} ) (V)</th>
</tr>
</thead>
<tbody>
<tr>
<td>50%</td>
<td>1.5197 &lt; 4 ( \frac{5}{5} )</td>
<td>1.075</td>
<td>1.074</td>
<td>59.849 &lt; .029 ( \frac{0}{0} )</td>
<td>103.662 &lt; 29.98</td>
</tr>
<tr>
<td>98%</td>
<td>2.976 &lt; 25</td>
<td>2.697</td>
<td>1.257</td>
<td>117.2 &lt; -20.02</td>
<td>203 &lt; 9.98</td>
</tr>
<tr>
<td>82.25%</td>
<td>2.5 &lt; 36.8 ( \frac{7}{7} )</td>
<td>2.000</td>
<td>1.499</td>
<td>98.456 &lt; -8.15</td>
<td>170.531 &lt; 21.84</td>
</tr>
<tr>
<td>123.38%</td>
<td>3.75 &lt; .963 ( \frac{3}{3} )</td>
<td>3.749</td>
<td>0.063</td>
<td>147.684 &lt; -44.07</td>
<td>255.796 &lt; -14.07</td>
</tr>
</tbody>
</table>

[1]
Table 3-2: Voltage Values for Station B before Islanding and for the First 16 cycles of Islanding

<table>
<thead>
<tr>
<th>Cycle(s)</th>
<th>Voltage(V)</th>
<th>Phase(°)</th>
<th>Voltage(V)</th>
<th>Phase(°)</th>
<th>Voltage(V)</th>
<th>Phase(°)</th>
<th>Voltage(V)</th>
<th>Phase(°)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>207.33</td>
<td>29.98</td>
<td>207.33</td>
<td>29.98</td>
<td>207.33</td>
<td>29.98</td>
<td>207.33</td>
<td>29.98</td>
</tr>
<tr>
<td>1-4</td>
<td>181.33</td>
<td>29.98</td>
<td>206.292 5</td>
<td>24.98</td>
<td>198.130 3</td>
<td>27.945 25</td>
<td>219.446 5</td>
<td>18.968 5</td>
</tr>
<tr>
<td>5-8</td>
<td>155.33</td>
<td>29.98</td>
<td>205.255</td>
<td>19.98</td>
<td>188.930 5</td>
<td>25.910 5</td>
<td>231.563</td>
<td>7.957</td>
</tr>
<tr>
<td>9-12</td>
<td>129.33</td>
<td>29.98</td>
<td>204.217 5</td>
<td>14.98</td>
<td>179.730 8</td>
<td>23.875 75</td>
<td>243.679 5</td>
<td>3.0545</td>
</tr>
<tr>
<td>13-16</td>
<td>103.33</td>
<td>29.98</td>
<td>203.18</td>
<td>9.98</td>
<td>170.531</td>
<td>21.841</td>
<td>255.796</td>
<td>14.066</td>
</tr>
</tbody>
</table>

The voltage phase angle changes in DG Setting 2 at 98% of apparent power, DG Setting 3 at 82.25% of apparent power, and DG Setting 4 at 123.38% of apparent power load as a result of the DG not being able to supply all the reactive power to the load.

A test similar to the previous test in Figure 3-1 was also modeled and tested, where the PV system was only connected to the A phase and could supply 98% of the apparent power. The voltage for phase A at Station B decreased from a value of 207.33V to 203.18V in 4 gradual steps of 4 cycles and
the phase remained at a constant value of 29.98\(^\circ\); the current for phase A remained at 8.464<-45.029. The voltages and currents for phases B and C immediately went to 0 when islanding occurred. The following Table 3-3 summarizes the transient reaction to this single phase DG. This power system will be referred to as setting 5.

**Table 3-3: Voltage and Current Values before Islanding and the First 16 Cycles during Islanding for a single Phase DG**

<table>
<thead>
<tr>
<th># of Cycles</th>
<th>Phase A</th>
<th>Phase B</th>
<th>Phase C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voltage L-L (V)</td>
<td>Current (A)</td>
<td>Voltage L-L (V)</td>
<td>Current (A)</td>
</tr>
<tr>
<td>Before islanding</td>
<td>207.33&lt;-29.98</td>
<td>8.464&lt;-45.029</td>
<td>207&lt;-90.02</td>
</tr>
<tr>
<td>1-4</td>
<td>206.292&lt;-29.98</td>
<td>8.464&lt;-45.029</td>
<td>0</td>
</tr>
<tr>
<td>5-8</td>
<td>205.255&lt;-29.98</td>
<td>8.464&lt;-45.029</td>
<td>0</td>
</tr>
<tr>
<td>9-12</td>
<td>204.175&lt;-29.98</td>
<td>8.464&lt;-45.029</td>
<td>0</td>
</tr>
<tr>
<td>13-16</td>
<td>203.18&lt;-29.98</td>
<td>8.464&lt;-45.029</td>
<td>0</td>
</tr>
</tbody>
</table>

3.2.3 **Current and Voltage phase differences:**

To set the Voltage Phase Jump Detection setting, the phases should be calculated by subtracting the difference between the voltage phase angle given in Table 3-2 above and the current’s phase angle is -45.029\(^\circ\). Because the SVP
uses radians, the angles need to be converted. The following equations are sample calculations that were done in Excel.

\[ \theta_{\text{normal}} = \theta_V - \theta_I = 29.98 - (-45.029) = 75.009^\circ \]  \hspace{1cm} 3-11

\[ \theta_{\text{normal}} = 75.009^\circ \left(\frac{\pi}{180}\right) = 1.309\text{rad} \]  \hspace{1cm} 3-12

The following Table 3-4 summarizes what was calculated.

**Table 3-4: Phase difference between the Voltage and Current at the PCC for Each DG Setting**
<table>
<thead>
<tr>
<th>DG Setting 1: 50% of Apparent Power</th>
<th>DG Setting 2: 98% of Apparent Power</th>
<th>DG Setting 3: 82.25% of Apparent Power</th>
<th>DG Setting 4: 123.38% of Apparent Power</th>
</tr>
</thead>
<tbody>
<tr>
<td>ΘV (°)</td>
<td>ΘI (°)</td>
<td>ΘV - ΘI (°)</td>
<td>ΘV - ΘI (rad)</td>
</tr>
<tr>
<td>30°</td>
<td>-45.029</td>
<td>-25.009</td>
<td>0.109115</td>
</tr>
<tr>
<td>30°</td>
<td>-45.029</td>
<td>-25.009</td>
<td>0.109115</td>
</tr>
<tr>
<td>30°</td>
<td>-45.029</td>
<td>-25.009</td>
<td>0.109115</td>
</tr>
<tr>
<td>30°</td>
<td>-45.029</td>
<td>-25.009</td>
<td>0.109115</td>
</tr>
<tr>
<td>30°</td>
<td>-45.029</td>
<td>-25.009</td>
<td>0.109115</td>
</tr>
</tbody>
</table>

DG Setting 1: 50% of Apparent Power
DG Setting 2: 98% of Apparent Power
DG Setting 3: 82.25% of Apparent Power
DG Setting 4: 123.38% of Apparent Power
Using the values calculated a phase of less than 1.30 rad was set to detect islanding.

3.2.4 Under/Over Voltage settings:

Assumption 1 states that the voltages will range from 166.4V to 249.6V. These numbers were calculated by multiplying the nominal voltage by 80% and 120%. Therefore, the Over/Under Voltage Detection was set to trip below 166.4V and above 249.6V.

3.2.5 Communication between the SVP and SEL-421

In order for the SEL-421 to send voltage and current phasors, the following steps have helped program the SEL-421 and the SVP.

3.2.5.1 Programming the SEL-421:

Step 1.
Repeat steps 1-6 from Detecting a fault using the SEL 421 section.

Step 2.
Go to the Synchronized Phasor Measurements tab and select the appropriate settings. An example is shown in Figure 3-19 and Figure 3-20

Note: The settings under this tab needs to match what is programmed on the SVP
Figure 3-19: Synchrophasor Settings for Station A Part 1

Figure 3-20: Synchrophasor Settings for Station A Part 2
Note: change PHDATAI to I1 when programming for Voltage Phase Jump Detection

Step 3.

Repeat Steps 1 through 3 for Substation B; use Figure 3-21 and Figure 3-22 to help with the settings.

Figure 3-21: Global Settings for Station B
3.2.5.2 SVP Configurator:

The SVP configurator is used to download programmed logic to the SVP.

The following steps have helped in setting up communication from the SEL 421 to the SVP and to view the information sent. In order to collect data using the SVP, the following Program Organization Units (POUs) have needed to be programmed in the project: Time Alignment Client Server, Phasor Measurement and Control Unit, Local PMCU, and watchdog.
Time Alignment Client Server (TCS):

The TCS POU takes the information read by the SVP from the SEL 421s and time aligns them so that logic calculations will be accurate. In order for the data to be used, the readings need to have an accurate timestamp from the GPS clock.

Step 4.
Moving to the SVP configurator, follow steps 1 through 16 of the TCS applications example given in the SEL-3378 Synchrophasor Vector Processor Instruction Manual and shown in Figure 3-23 below.
Figure 3-23: Directions From the SVP Manual to Program the TCS POU [12]

Step 5.

Declare the variables in the given area as shown in Figure 3-24 below

Figure 3-24: Variables Used for the TCS POU
Step 6.

In order to read information from the SEL 421, settings of how the SEL 421 is going to communicate with the SVP need to be programmed. The following Figure 3-25 shows how to program the SVP to communicate with two SEL 421s that are serially connected. *Note: Make sure that the settings match the SEL 421 settings, especially watch out for the ID code, Connection Speed, Message Rate, and Message Format.*
Step 7.

Compile by going to Project→ Clean All, then Project→ Rebuild all.

Step 8.

To send the program to the SVP, the communications parameters need to be set. The IP address for this SVP is 129.65.138.125.

Go to Online→ Communications Parameters→ New and use the parameters shown in Figure 3-26 below.
Step 9.
Send the program to the SVP by going to Online → Login, Online → Run

Step 10.
Logout and work on the next POU by going to Communications → Logout.

**Phasor Measurement and Control Unit:**

The Phasor measurement and control unit accesses the data collected by the TCS.

Step 11.
Follow Steps 1 through 11 from the SVP Instructions Manual to make a new POU shown in Figure 3-27 below.
Step 12. Follow Steps 1 through 5 to add the PMCU_IN functional block.

Step 1. Click the PMCU tab, double-click PMCU_Assign, then click in the programming space.

Step 2. Add a box by clicking the icon found on the menu bar, or by right-clicking within the programming space.

Step 3. Replace the default name (AND) with PMCU_IN, and click outside the box. Figure 3-28 shows the PMCU_IN function block assigned to PMCU with IDCODE 125.

Step 4. Program EN input to TRUE, or assign this input to a variable of Boolean type.

Step 5. Program IDCODE input to 125.

This IDCODE should match the PMCU_ID of the target PMCU. Each PMCU_IN should be associated with a unique instance name.

Figure 3-28: How to Program the PMCU using Functional Blocks from the SVP Instructions Manual [12]

Step 13. Replace the question marks “???” on the top of the functional block with StationA
Step 14.

For Station B, right click in the program space and select network (after) as shown below in Figure 3-29.

Figure 3-29: How to add a new network using the FBD type POU

Right click again and add Box, write PMCU_IN in place of the “and,” then put “456” in the ID code and true for the EN inputs and StationB in place of the question marks “???” The finished product should look like Figure 3-30 below.
Step 15.
Compile by going to Project→ Clean All, then Project→ Rebuild all. Send the program to the SVP by going to Online→ Login, Online →Run.

Step 16.
Logout and work on the next POU by going to Communications→ Logout.

Local PMCU:

The Local PMCU is an object that will take the information read by the SVP into a readable format outside of the SVP Configurator.
Step 17.

Got to Project → Object→ Add and in the New POU window, select ST and name it LocalPMCU

Step 18.

Go to the Resources tab and double click on Task configuration. Go to the High Speed applications and right click and select insert program call. Press the browse button and look for LocalPMCU and add it. The Figure 3-31 below shows how the Task Configuration should look after the program call is added.

![Figure 3-31: How to Append a Task using Task Configuration](image_url)

Step 19.
Declare the following variables shown in Figure 3-32 below.

![Figure 3-32: Variables for the PMCU out POU](image)

**Step 20.**

In the programming section, input the following settings to output the measurement data. The Server is the SVP’s IP address and the client is the computer's IP address.

```plaintext
out_cfg_pmcu.PDC_IDCODE:=1;
out_cfg_pmcu.STN_NAME:= 'SVP';
out_cfg_pmcu.CLIENT_IP:= '129.65.138.184';
out_cfg_pmcu.CLIENT_DATA_PORT:=8765;
out_cfg_pmcu.SERVER_IP:='129.65.138.125';
out_cfg_pmcu.SERVER_CMD_PORT:=5678;
out_cfg_pmcu.MRATE:=60;
out_cfg_pmcu.NFREQ:=60;
out_cfg_pmcu.NUM_PO_V:=2;
out_cfg_pmcu.PH_RECT_FMT:= TRUE;
out_cfg_pmcu.CFG_CNT:=1;

out_dat_pmcu.SOC:=StationA.SOC;
out_dat_pmcu.FOS_USEC:=StationA.FOS_USEC;
out_dat_pmcu.PO_V[1].RE:=StationA.PI[1].RE;
out_dat_pmcu.PO_V[1].IM:=StationA.PI[1].IM;
out_dat_pmcu.PO_V[2].RE:=StationB.PI[1].RE;
out_dat_pmcu.PO_V[2].IM:=StationB.PI[1].IM;
out_dat_pmcu.FREQ:=StationA.FREQ;
out_dat_pmcu.DFDT:=StationA.DFDT;
out_dat_pmcu.TQ:=0;
out_dat_pmcu.STATUS:=0;
```
IF (StationA.OK OR StationB.OK) AND (StationA.FOS_USEC = StationB.FOS_USEC) THEN PMCU_OUT(TRUE, ADR(out_cfg_pmcu), ADR(out_dat_pmcu), ADR(pmcu_error));
END_IF

Step 21.
Compile by going to Project→ Clean All, then Project→ Rebuild all. Send the program to the SVP by going to Online→ Login, Online →Run.

Step 22.
Logout and work on the next POU by going to Communications→ Logout.

**Watchdog:**

The watchdog prevents the SVP from timing out.

Step 23.
Go to Project → Object→ Add, and in the New POU window select FBD type and name it watchdog.

Step 24.
Go to the Resources tab and double click on Task configuration. Go to the TSCConfiguration and right click and select insert program call. Press the browse button and look for watchdog and add it.

Step 25.
Click into the programming area and press Control B to add a box. Replace the “And” with USER_WATCHDOG.
Step 26.
Compile by going to Project→ Clean All, then Project→ Rebuild all. Send the program to the SVP by going to Online→ Login, Online →Run.

Step 27.
Logout and work on the next POU by going to Communications→ Logout.

3.2.5.3 PDC Assistant:
To retrieve the data in a readable format, use the PDC assistant

Step 28.
Open the PDC Assistant and start the Syncrowave PDC by going to Start →SEL Applications→SEL-5073 SyncroWAVe PDC→ Start SEL-5073 as shown in Figure 3-33 below.
Figure 3-33: How to Start PDC Assistant

Step 29.

Select the input tab and select Add PDC. Input the following settings shown in Figure 3-34 below.

*Note: The settings in this section match those programmed in the LocalPMCU section.*
Step 30.

Press the connect button and fill in the following settings shown in Figure 3-35 below, where the password is ott3rTAI!
Figure 3-35: How to Connect to the PDC using the PDC Assistant

Step 31.
Add a continuous archive by pressing Add Continuous Archive and fill out the data shown in Figure 3-36 below.
Figure 3-36: Collecting Data from the SVP using a Continuous Archive

Step 32.
To retrieve the data, click retrieve archives and fill out the format type desired, shown in the Figure 3-37 below.
Figure 3-37: Setting of where the Archived Data will go and How it is Formatted

Note: to retrieve data, the PDC Assistant needs to be connected to the PDC

Step 33.

Click on the data desired and press export, shown in Figure 3-38 below
Step 34.
View the data in excel

3.2.6 Programming the Voltage Phase Jump and Under/Over Voltage:

The following steps have helped program the Voltage Phase Jump. The Voltage Phase Jump will trip when the phase angle falls below 1.3 and will not send another trip signal until it rises above 1.2 and falls again to ensure there is no re-tripping action.

Step 1.
Go to Project → Object→ Add and in the New POU window select ST and name it VoltagePhaseJump
Step 2.
Declare alarming, anglediff, current, and angle as global variables; angle, current, and anglediff should be arrays of 5 real values; alarming should be a Boolean variable.

Step 3.
Input the following code in the program space:

```plaintext
IF value<5 AND StationB.OK THEN
    angle[value] := StationB.PI[1].ANG;
    current[value] := StationB.PI[2].ANG;
    anglediff[value] := angle[value] - current[value];
    IF anglediff[value]< 1.30 THEN
        alarming := TRUE;
    END_IF;
    IF anglediff[value]>1.2 THEN
        alarming := FALSE;
    END_IF;
    value := value+1;
    IF value=5 THEN
        value := 1;
    END_IF;
END_IF;
```

The above code takes the voltage and current angle readings from Station B every time a new and valid reading comes in. The values are stored in angle and current and the difference between the two is put in anglediff. An if-statement is used to determine if a signal should be sent to RB01. If anglediff is less than 1.30 rad, then alarming will be true and another object will be used to send a bit to RB01.
Step 4.
Go to the Resources tab and double click on Task configuration. Go to the High Speed applications and right click and select insert program call. Press the browse button and look for VoltagePhaseJump and add it.

*Note: The program will not run unless the POU is added to a task.*

Step 5.
Compile by going to Project→ Clean All, then Project→ Rebuild all. Send the program to the SVP by going to Online→ Login, Online →Run.

Step 6.
Logout and work on the next POU by going to Communications→ Logout.

Step 7.
Go to Project → Object→ Add and in the New POU window select POU type and name it AngleCheck.

Step 8.
Use the add box and add input buttons on the top to help build the logic in the Figure 3-39 below. For each box, replace the question marks “???” with the name of the logic block desired. To connect the inputs to the boxes, click at the end of the input line and drag it to the desired location on the logic block. Declare the variables above.
Figure 3-39: POU that Sends a Bit to RB01

When alarming is true and goes into the trigger function block, a pulse is sent to the enable of the fast operating remote bit pulse function block. This function block will send a pulse to Remote Bit 01 to Relay 456, which is the Station B relay.

Step 9.
Go to the Resources tab and double click on Task configuration. Go to the High Speed applications and right click and select insert program call. Press the browse button and look for AngleCheck and add it.
Step 10.
Compile by going to Project→Clean All, then Project→Rebuild all. Send the program to the SVP by going to Online→Login, Online→Run.

Step 11.
Logout and work on the next POU by going to Communications→Logout.

Step 12.
In order for the RB01 to trip, the SEL-421 at Station B needs to put RB01 in its trip logic. Use AcSelerator QuickSet and go to Group1→Set 1→Relay Configuration→Trip Logic and add RB01 to it. The following Figure 3-40 shows the settings.

![Figure 3-40: Trip Logic in the SEL 421 Station B](image-url)
The next object will be used to program the under/over voltage detection method. The following steps have helped in programming this object. When the voltage is under 166.4V or over 249.6V then a signal will be sent to RB01. Like the voltage phase jump detection method, the signal will only be sent again once the voltage falls between 166.4V and 249.6V and then falls over or under again to ensure no re-tripping occurs.

Step 13.
Go to Project → Object→ Add and in the New POU window select ST and name it UnderOverVoltage

Step 14.
Declare the VoltageB to be a global array of 8 real values and value as a local integer variable.

Step 15.
Input the following code into the program box:

```plaintext
IF StationB.OK THEN
  VoltageB[value] := StationB.PI[1].MAG;
  IF VoltageB[value] < 166.4 THEN
    alarming := TRUE;
  END_IF;
  IF VoltageB[value] > 166.4 AND VoltageB[value] < 249.6 THEN
    alarming := FALSE;
  END_IF;
  IF VoltageB[value] > 249.6 THEN
    alarming := TRUE;
  END_IF;
  value := value + 1;
IF value = 8 THEN
```

Page 73
value:= 1;
END_IF;
END_IF;

This code takes in the magnitude of the voltage at Station B every time there is a new value read by the SVP. The value is then checked to see if it falls between 166.4V and 249.6V; if the value does not fall between the two values, then alarming is true and will be sent to the CheckAngles object shown above. The CheckAngles Object will then send a trip signal to RB01.

Step 16.
Go to the Resources tab and double click on Task configuration. Go to the High Speed applications and right click and select insert program call. Press the browse button and look for UnderOVerVoltage and add it.

Step 17.
Compile by going to Project→ Clean All, then Project→ Rebuild all. Send the program to the SVP by going to Online→ Login, Online →Run.

Step 18.
Logout and work on the next POU by going to Communications→ Logout.

3.2.7 Programming the GPS Clock:
In order for the SVP to accurately read the voltage and current phasors from the SEL-421s, the SEL-421s and the SVP need an accurate time stamp;
this can be given with the GPS Clock. The GPS clock needs to send the information using the IRGB-B000 with the IEEE 1344 and IEEE C37.118 extensions format for the SEL 421 to read the correct time. For the SVP to read the GPS clock, the GPS clock needs to send information using the IRIG-B002 format.

The following steps has helped program the GPS clock to send an accurate time to the SEL421s and the SVP.

Step 1.
Open the front cover of the GPS clock

Step 2.
Program the switches according to Table 3-1 below. If there is a '-' symbol just leave as is.

**Table 3-5: GPS Clock Settings**

<table>
<thead>
<tr>
<th>Switch</th>
<th>On/Off</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>-</td>
<td>Password protection</td>
</tr>
<tr>
<td>2</td>
<td>-</td>
<td>If Satellite lock is included with alarm (satellite lock is when the clock loses signal form the antenna and gives a time according to the last signal received)</td>
</tr>
<tr>
<td>3</td>
<td>-</td>
<td>What happens during an alarm</td>
</tr>
<tr>
<td>4</td>
<td>-</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>-</td>
<td>Output IRIG format</td>
</tr>
<tr>
<td>6</td>
<td>On</td>
<td>Out 1 configuration (connected to SEL421 Station A)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>7</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>On</td>
<td>Out2 configuration (connected to SEL 421 Station B)</td>
</tr>
<tr>
<td>9</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Off</td>
<td>Out3 configuration (connected to SVP)</td>
</tr>
<tr>
<td>11</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Off</td>
<td>Local Time offset</td>
</tr>
<tr>
<td>13</td>
<td>on</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>On</td>
<td>Daylight Savings</td>
</tr>
<tr>
<td>19</td>
<td>-</td>
<td>Even or odd parity for the IRIG format</td>
</tr>
<tr>
<td>20</td>
<td>-</td>
<td>Out 6 Configuration</td>
</tr>
</tbody>
</table>

The GPS clock needs to be connected to the antenna with the given cable; the antenna needs to be mounted such that it has 360° of visibility. The SEL-421s and the SVP will be connected to the GPS clock with a BNC to BNC cable.

### 3.2.8 Using the SEL5401 to program test cases:

Each AMS is connected to an SEL 421 by a C724 cable. The C724 is connected to the SEL 421 where the transformer cable should be; the following Figure 3-41 shows the location of the cable. The C724 is connected in the back
of the AMS. The AMS is connected serially to the computer to download and run program test cases.

Figure 3-41: Connecting the AMS to the SEL 421

The following steps have helped program the AMS to run the test cases.

Step 1.
Open the SEL 5401 program.

Step 2.
Go to Configuration→ Relay Configuration and Choose SEL421 as shown in Figure 3-42.
Step 3.

Press the extended tab and fill in the current and voltage magnitude and phase (in degrees) that are provided for each DG setting given in Table 3-2.

*Note: The Phase B voltages and currents are -120 degrees off from Phase A and Phase C is 120 degrees off from Phase A.*

The first state is the normal condition and runs for 20 seconds. In the bottom left corner there is the option to changes states if the inputs change in some way; in this case there is none; the state changes when the time runs out. The bottom right hand corner tells the AMS what state to go to after State1 according to IN1, IN2, and IN3; in this case, no matter what the input, is the next state will be State 2. Figure 3-43 shows the values for State 1 of the test.
Figure 3-43: State 1 of the AMS Test

Step 4.

To add another state, press append state button as shown in Figure 3-44. The next 4 state will model the first 16 cycles of islanding; each of the four state times will be 4 cycles and follow Table 3-2.

Figure 3-44: Adding another State to the Test

Step 5.

After filling out the 4 islanding states, press the download and run button to test the case as shown in Figure 3-45.
For Station A, there are two states, islanding and normal. The normal state is state 1, where the Phase A values are V= 208<30V and I= 8.464<45A, which runs for 20 seconds and then Islanding is state 2 where the voltages and currents stay the same.

### 3.2.9 Running the Tests:

Each of the four DG settings were tested 5 times with the Voltage Phase Jump method and the Under/Over Voltage method. To test the Under/Over Voltage method separately, take the VoltagePhaseJump object out of the program call under task configuration. Likewise, take the UnderOverVoltage object out of the program call to test the Voltage Phase Jump Method only. The results of testing the four DG settings and a single phase DG setting are shown in the next chapter.
4 Test results

4.1 Setting 1: 50% of Apparent Power:

Setting 1 was chosen to show what would happen if the DG produced apparent power at the same angle as the, load showing the Voltage Phase Jump detection’s short comings.

Setting 1 was inputted into the AMS (SEL-5401) and ran 5 times using each detection method, the results are shown below. The voltage detection followed the IEEE 1547 standard of tripping before 5 seconds. The voltage phase jump detection method does not trip because the phase difference between the current and voltage does not change during islanding. Although the Voltage Phase Jump detection did not detect islanding, the SVP is programmed to trip if either of the two methods is detected. Therefore, the SVP’s detection methods follow the IEEE 1547 standard. The following Table 4-1 summarizes the results.

Table 4-1: Results for DG Setting 1 tests

<table>
<thead>
<tr>
<th>Iteration</th>
<th>Voltage detection (#of cycles)</th>
<th>Voltage Phase Jump detection (# of cycles)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>7.75</td>
<td>no detection</td>
</tr>
<tr>
<td>2</td>
<td>7.75</td>
<td>no detection</td>
</tr>
<tr>
<td>3</td>
<td>7.75</td>
<td>no detection</td>
</tr>
<tr>
<td>4</td>
<td>7.75</td>
<td>no detection</td>
</tr>
<tr>
<td>5</td>
<td>7.75</td>
<td>no detection</td>
</tr>
</tbody>
</table>
The following graph, Figure 4-1, shows a few cycles before and after the SEL 421 sends a trip signal to the CB. It takes about 3 cycles for the RB01 signal to be sent and a trip signal sent out to the CB once the voltage falls below 166.4 V. The numbers in the boxes on the graph indicate which cycle is occurring after islanding has occurred.

**Note:** Because there was no CB connected to the actual device the voltage and current did not decrease to zero after the trip signal was given. In real life settings, the voltage and current will decrease to zero after the trip

![Figure 4-1: Phase A Voltage and Current during Islanding using Under/Over Voltage Detection Method for Setting 1](image-url)
4.2 Setting 2: 98% of Apparent Power

Setting 2 was chosen to show what would happen if the DG produced an apparent power where the voltage at the load would not drop below 80% of the load showing the Under/Over Voltage detection’s shortcomings.

Setting 2 was inputted into the AMS (SEL-5401) and ran 5 times using each detection method the results are shown below in Table 4-2. The voltage phase jump detection followed the IEEE 1547 standard of tripping before 5 seconds. The under/over voltage detection method does not trip because the voltage does not fall under 166.4V or over 249.6V. Using the SVP, a pulse could be sent if either of the two detection methods was found to be true. Having two different detection methods can encompass more cases than only one method.

Table 4-2: Results for DG Setting 2 Tests

<table>
<thead>
<tr>
<th>Iteration</th>
<th>Voltage detection (#of cycles)</th>
<th>Phase Jump detection (# of cycles)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>2</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>3</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>4</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>5</td>
<td>no detection</td>
<td>9.5</td>
</tr>
</tbody>
</table>
The following graph in Figure 4-2 shows a few cycles before and after the SEL 421 sends a trip signal to the CB2. It takes about 3 cycles for the RB01 signal to be sent and a trip signal sent out to the CB2 once the phase falls below 1.3 rad. In this case the phase falls below 1.3 rad within the first 4 cycles of islanding. The numbers in the boxes on the graph indicate which cycle is occurring after islanding has occurred.

Figure 4-2 Phase A Voltage and Current during Islanding using Voltage Phase Jump Detection Method for Setting 2
Figure 4-3: Normal Phase Difference Angles (75 degrees)

Figure 4-4: Phase Difference at 0.5 cycles is 70 degrees
Figure 4-5: Phase Difference at 4 cycles is 65 degrees

The phasor graph shown in Figure 4-3 is from the DG Setting 1; in that setting there is no phase change and shows normal a difference of 75 degrees. Figure 4-4 shows the phase difference of 70 degrees during the DG Setting 2 test and is at 0.5 cycles of the graph in Figure 4-2. In Figure 4-5, the phase difference between the current and the voltage is 65 degrees; this is the first time the phase difference drops to 65 degrees. From the data, it can be calculated that it took 9.5 cycles to detect islanding.

4.3 Setting 3: 82.25% of Apparent Power

Setting 3 was chosen to show what would happen if the DG produced an apparent power was not at the same angle as the load. The phase and voltage changed gradually and in small increments, making it harder to detect.
Setting 3 was inputted into the AMS (SEL-5401) and ran 5 times using each detection method the results are shown below. The phase detection followed the IEEE standard of tripping before 5 seconds. The voltage detection method does not trip because the voltage does not fall under 166.4V or over 249.6V. Using the SVP, a pulse could be sent if either of the two detection methods was found to be true Table 4-3 summarizes the results.

Table 4-3: DG Setting 3 Test Results

<table>
<thead>
<tr>
<th>Iteration</th>
<th>Voltage detection (#of cycles)</th>
<th>Phase Jump detection (# of cycles)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>2</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>3</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>4</td>
<td>no detection</td>
<td>9.5</td>
</tr>
<tr>
<td>5</td>
<td>no detection</td>
<td>9.5</td>
</tr>
</tbody>
</table>

The following graph in Figure 4-6 shows a few cycles before and after the SEL 421 sends a trip signal to the CB. In this case the phase falls below 1.3rad within the first 4 cycles of islanding, it takes about 9.5 cycles total for the SVP to detect islanding and for the SEL 421 to send a trip signal. The numbers in the boxes on the graph indicate which cycle is occurring after islanding has occurred. Figure 4-7 shows that at cycle two of the graph in Figure 4-6 the phase angle between the current and voltage decreases to about 70 degrees, this means that cycle 2 correlates with 5 cycles after islanding has occurred.
Figure 4-6: Phase A Voltage and Current during Islanding using Voltage Phase Jump Detection Method for Setting 3

Figure 4-7: DG Setting 3 Phase Difference at 5 Cycles After Islanding
4.4 Setting 4: 123.38% of Apparent Power

Setting 4 was chosen to see how the SVP would react to reading an overvoltage at the Load.

Setting 4 was inputted into the AMS (SEL-5401) and ran 5 times using each detection method the results are shown below. The phase detection and voltage detection followed the IEEE standard of tripping before 5 seconds. Using the SVP, a pulse could be sent if either of the two detection methods was found to be true. Although both detection methods sent a trip signal, having both detection methods can make islanding detection faster than just having the Voltage Detection method, tripping in 4 cycles rather than 15 cycles. The following Table 3-1 summarizes the results.

**Table 4-4: Test Results for DG setting 4**

<table>
<thead>
<tr>
<th>Iteration</th>
<th>Voltage detection (# of cycles)</th>
<th>Phase Jump detection (# of cycles)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>15</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>15</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td>4</td>
</tr>
<tr>
<td>4</td>
<td>15</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>15</td>
<td>4</td>
</tr>
</tbody>
</table>

The following graph in Figure 4-8 shows a few cycles before and after the SEL 421 sends a trip signal to the CB. The SVP detection method for this figure
is the over/under voltage. In this case, the SVP detected an overvoltage 13 cycles after islanding has occurred. This is because detection only happens after the voltage is increased over 249.6V. About 3 cycles after detection, a trip signal is sent to the CB, making a total of about 15 cycles until detection. This detection method satisfies the IEEE 1547 standard. The numbers in the boxes on the graph indicate which cycle is occurring after islanding has occurred.

Figure 4-8 Phase A Voltage and Current during Islanding using Over/Under Voltage Detection Method for Setting 4

The following graph in Figure 4-9 shows a few cycles before and after the SEL 421 sends a trip signal to the CB. It takes about 3 cycles for the RB01 signal to be sent and a trip signal sent out to the CB once the phase falls below 1.3 rad.
In this case the phase falls well below 1.3rad within the first 4 cycles of islanding and is much faster than the over/under voltage detection and also satisfies the IEEE 1547 standard. The numbers in the boxes on the graph indicate which cycle is occurring after islanding has occurred.

Figure 4-9: Phase A Voltage and Current during Islanding using Voltage Phase Jump Detection Method for Setting 4
Figure 4-10: DG Setting 4 using Voltage Phase Jump Detection Method at Cycle 3.5 which Correlates to cycle 1

Figure 4-10 shows the angle between the current and voltage fall to about 70 degrees; this proves that at 3.5 cycles on Figure 4-9 correlates with cycle 1 after islanding. This means that it takes 4 cycles to detect islanding using the Voltage Phase Jump method.

4.5 Setting 5: Single Phase Distributed Generation

Setting 5 was chosen to simulate a similar power system as the one in the preliminary design.

Setting 5 was inputted into the AMS (SEL-5401) and ran 5 times using each detection method the results are shown below. The voltage detection followed the IEEE 1547 standard of tripping before 5 seconds. Using the SVP, a
pulse could be sent if either of the two detection methods was found to be true; therefore, even though the Voltage Jump Phase Detection method did not trip, the SVP’s detection method tripped. The following Table 4-5 summarizes the results.

Table 4-5: DG Setting 5, Having a Single Phase DG, Test Results

<table>
<thead>
<tr>
<th>Iteration</th>
<th>Voltage detection (# of cycles)</th>
<th>Voltage Phase Jump detection (# of cycles)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3</td>
<td>no detection</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>no detection</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>no detection</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>no detection</td>
</tr>
<tr>
<td>5</td>
<td>3</td>
<td>no detection</td>
</tr>
</tbody>
</table>

The following graph, Figure 4-11, shows a few cycles before and after the islanding detection and a trip signal was sent. The SVP detection method for this figure is the over/under voltage. In this case the SVP detected an under voltage within the first cycle of islanding. This detection method satisfies the IEEE 1547 standard. The numbers in the boxes on the graph indicate which cycle is occurring after islanding has occurred.
Figure 4-11: Phase A and B Voltage and Phase A Current during Islanding using Over/Under Voltage Detection Method for Setting 5

Even though the Phase A voltage was above 166.4V, the reason why the Over/Under Voltage detected is because the voltage and phase values that were sent were the positive sequence values, not the Phase A values. The previous examples had balanced systems so the positive sequence equaled the Phase A values. The equations below will further explain.

The values of voltage and current of the first 4 cycles of islanding will help explain.
\[
\begin{bmatrix}
V_0 \\
V_1 \\
V_2
\end{bmatrix} =
\begin{bmatrix}
1 & 1 & 1 \\
1 & 1 < -120 & 1 < 120 \\
1 & 1 < 120 & 1 < -120
\end{bmatrix}^{-1} \begin{bmatrix}
V_{AB} \\
V_{BC} \\
V_{CA}
\end{bmatrix} =
\begin{bmatrix}
1 & 1 \\
1 & 1 < -120 \\
1 & 1 < 120 & 1 < -120
\end{bmatrix}^{-1} \begin{bmatrix}
206.29 < 29.98 \\
0 \\
0
\end{bmatrix} = \begin{bmatrix}
68.764 < 29.98 \\
68.764 < 29.98 \\
68.764 < 29.98
\end{bmatrix}
\]

Therefore, the Positive sequence voltage magnitude is actually 68.754V and is well below 166.4V. The Positive sequence of the current is 2.821<-45.029 by the following equation.

\[
\begin{bmatrix}
I_0 \\
I_1 \\
I_2
\end{bmatrix} =
\begin{bmatrix}
1 & 1 & 1 \\
1 & 1 < -120 & 1 < 120 \\
1 & 1 < 120 & 1 < -120
\end{bmatrix}^{-1} \begin{bmatrix}
I_A \\
I_B \\
I_C
\end{bmatrix} =
\begin{bmatrix}
1 & 1 \\
1 & 1 < -120 \\
1 & 1 < 120 & 1 < -120
\end{bmatrix}^{-1} \begin{bmatrix}
8.464 < -45.029 \\
0 \\
0
\end{bmatrix} = \begin{bmatrix}
2.821 < -45.029 \\
2.821 < -45.029 \\
2.821 < -45.029
\end{bmatrix}
\]

This means that the phase difference between the voltage and current at the load is above 1.3rad and the Voltage Phase Jump detection method will not detect islanding.

\[
\theta_{V-I} = \theta_V - \theta_I = 29.98 - (-45.029) = 75.009^\circ
\]

\[
\theta_{V-I} = 75.009^\circ \left( \frac{\pi}{180} \right) = 1.309\text{rad}
\]
5 Conclusion:

As Distributed Generation becomes more popular, so does the need to detect islanding. The safety of network personnel and foremen, system reliability, power quality, and equipment protection rely on accurate island detection. As seen in the test results, no matter what detection method is used, there will always be a case where detection is not possible. For this reason, using multiple detection methods will make detection more reliable. If the system has large NDZ for one method it may not for another. The SVP is very malleable and can incorporate many different detection methods; it can keep up with the ever changing power system. Because each system is so different, individual analysis of the system must be made to determine detection settings. Even though settings look good on paper, testing should always be done to ensure reliability.
6 Future Studies:

There is always more that could be done; each passive method in the Background section could be tested using the SVP. An ideal combination of the different passive methods could be chosen. Also, cost analysis of active vs. passive detection methods could be done. Another thesis topic could be to collect data from the surrounding utility companies and analyze the islanding data they have; with that, new passive methods could be created and a better model could be implemented into the AMS. Because of the communication restraints on the AMS, slip, frequency, and acceleration could not be tested. Research could be done to find different test equipment that could model continuous change in voltage and current to test frequency shift, slip, acceleration, and under/over frequency. Also, a student could build their own inverter that does not need a reference AC voltage to supply an AC load and test the power system designed in the preliminary design.

6.1 Other passive methods:

SVP logic can be programmed to do many different passive detection methods. For example, to calculate slip, acceleration, and frequency of the output voltage, the following simple object could be added to SVP project.

```
IF value<2 AND StationB.OK THEN
    angle[value] := StationB.PI[1].ANG ;
    current[value] := StationB.PI[2].ANG;
    anglediff[value] := angle[value] -current[value];
    IF anglediff[value]< 1.30 THEN
        alarming := TRUE;
    END_IF;
```
IF anglediff[value] > 1.2 THEN
    alarming := FALSE;
END_IF;
value := value + 1;
END_IF;

IF value > 1 AND value < 3 AND StationB.OK THEN
    angle[value] := StationB.PI[1].ANG;
    current[value] := StationB.PI[2].ANG;
    anglediff[value] := angle[value] - current[value];
    Frequency := (angle[value] - angle[value-1]) * 60 / (2 * 3.14);
    slip[value-1] := (angle[value] - angle[value-1]);
    acceleration[value-2] := (slip[value-1] - slip[value-2]);
END_IF;

IF anglediff[value] < 1.30 THEN
    alarming := TRUE;
END_IF;

IF anglediff[value] > 1.2 THEN
    alarming := FALSE;
END_IF;

IF slip[value-1] > # THEN
    alarming := TRUE;
END_IF;
IF slip[value-1] < # OR slip[value-1] = # THEN
    alarming := FALSE;
END_IF;
value := value + 1;
END_IF;

IF value > 2 AND value < 5 AND StationB.OK THEN
    angle[value] := StationB.PI[1].ANG;
    current[value] := StationB.PI[2].ANG;
    anglediff[value] := angle[value] - current[value];
    slip[value-1] := (angle[value] - angle[value-1]);
    acceleration[value-2] := (slip[value-1] - slip[value-2]);
    Frequency := (angle[value] - angle[value-1]) * 60 / (2 * 3.14);
    IF anglediff[value] < 1.3047 THEN
        alarming := TRUE;
    END_IF;
    IF anglediff[value] > 1.2 THEN
        alarming := FALSE;
    END_IF;
    IF slip[value-1] > # OR acceleration[value-2] > # THEN
        alarming := TRUE;
    END_IF;
    IF slip[value-1] < 1 # OR slip[value-1] = # OR acceleration[value-2] < 1 # OR acceleration[value-2] = # THEN
By looking at data from PG&E or other utilities, a better model could be found and slip, frequency change, and acceleration detection settings can be calculated and tested. Other passive methods mentioned can be researched more in depth and implemented in the SVP as well. For example, using the voltage and current readings from Station A and comparing them to Station B could be another detection method that can be tested. The AMS was not able to test this method because the two AMSs could not be started at the exact same time; therefore, the voltage phase between the two stations was changing from test to test. There was also no way to connect the two AMSs to start them at the same time.

6.2 New Passive methods:

By looking at the voltage and current readings of both before and after the Point of Common Coupling (PCC), new patterns of differences between islanding and non-islanding characteristics can be found. These could be used to detect if islanding has occurred.
6.3 Cost analysis:

A cost analysis of passive vs. active methods of islanding detection could be done. Things such as cost of having the system down longer, replacing equipment, maintenance, and initial cost could be taken into account. Data from different utilities can be used to make the study more accurate. The analysis of cost can be compared to what is already implemented to see how many years it would take the new method to pay off.
References


Appendices

A. SEL 421 and SEL 311 Labs

B. Detecting Incorrect Input Settings for the AMS
APPENDIX A: SEL 421 and SEL 311 Labs

SEL 421 Digital Relay

SEL 421 is a microprocessor based relay with multifunction characteristics. This unit can be programmed for Instantaneous Overcurrent, Time Overcurrent, Impedance, Over- and Under-voltage, and metering.

Equipment List:

- 6 40mH Chokes
- 6 10 ohm Power Resistors
- 3 25 ohm Power Resistors
- 3 Current Transformers
- 3 Potential Transformers
- 1 Fault Box

Procedure:

Relay Communication Set-up:

1. Relay Parameters
   a. On the front screen of the relay select Ent until you get to the Main Menu. Select Set/Show Port 1 Communication Setting and then record the following:

<table>
<thead>
<tr>
<th>Bits per second</th>
<th>Data bits</th>
<th>Parity</th>
<th>Stop bits</th>
<th>Flow control</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2. PC Parameters Set-up
   a. From Start, Right-click My Computer Manage, Device Manager under system tools Ports (COM and LPT) Double-click Communications Port (COM1) Port Setting and set the port settings that matches the relay parameters settings recorded in the above table.

Relay Parameters Set-up:

1. Open the AcSELerator Quickset and click on New Settings. Select the number of the relay that matches the relay in use. On the front screen of the relay click Esc until you get to the Main Menu. Select View Configuration and view the FID of the relay. On the PC screen select the relay that matches the front screen of the relay.
2. On the PC screen enter the Part Number that matches the number you see on the front screen of the relay under View Configuration.
3. Click on **Communications** and set the parameters.
   a. Set using Setting Editor
      i. **Under General Global Setting:**
         - **SID** (Station Identifier) = Station 1
         - **RID** (Relay Identifier) = Relay 1
         - **NUMBK** (Number of Breakers in the circuit) = 1
         - **BID** (Breaker Identifier) = Breaker 1
         - **NFREQ** (Nominal System Frequency) = 60Hz
         - **PHROT** (System Phase Rotation) = ACB
         - **DATE-F** (Date Format) = MDY
         *Current and Voltage Source Selection:* Set ESS to N this allows the relay to get its currents and voltages from W and Y terminals respectively (on the back of the relay).
         Leave everything else as is.
      ii. **Breaker Monitor:** Set BK1 TYP BK1 to 3 and 52AA1 N/O to IN101.
      iii. **Group1 Set 1**
          
          *Line Configuration:*
          - **CTRW** (Current transformer turns ratio) = 2
          - **PTRY** (Potential transformer turns ratio) = 2
          - **VNOMY PT** (Voltage applied the relay) = 208
          - **Z1 MAG** (Magnitude of the positive sequence impedance of the line) = 36.19
          - **Z1 ANG** (Angle of the positive sequence impedance of the line) = 56.45
          - **Z0 MAG** (Magnitude of the zero sequence impedance of the line) = 108.56
          - **Z0 ANG** (Angle of the zero sequence impedance of the line) = 56.45
          - **EFLOC** (Fault Location): y
          - **LL** (Line Length): 100

          *Relay Configuration*
          
          *Phase Distance Element:*
          - **E21P** (Number of zones) = 1
          - **Z1P** (Zone 1 impedance) = 28.95
Z1PD (Zone 1 time delay) = 0

**Ground Distance Element** (Same as Phase Distance Element)

**Phase Inst. O/C:** E50P (N)

**Time Overcurrent:** E51S (N)

**Directional:** E32 (AUTO)

**ORDER:** (QV)

**Reclosing:** E79 (N)

**EMANCL:** (N)

**Trip Scheme:** ECOMM (N)

*Leave everything else as is*

4. Check that the Trip Logic (TR SELOGIC) = M1P OR Z1G
5. Save the file
6. Transferring the file: Select *File > Send* to transmit the settings to the relay.
7. Set up the circuit below

*Note: the circuit breaker can be powered with either 125V DC or 120V AC*

---

![Circuit Diagram](image-url)

**Figure 0-1 Circuit diagram for SEL 421 digital relay**

The following are pictures to help set up the circuit
Voltages are connected here:

Figure 0-2: Where to connect the Voltage Readings

Breakers are attached here:
Figure 0-3: 3 Phase Breakers Attached to Out 105 to
Currents are connected here:

Figure 0-4: Output Current from the Current Transformers are Connected in the $I_W$ section

8. Open a terminal window by clicking on the terminal button on the far right of the main terminal bar in AcSELerator.
9. Connect the Fault box for single line to ground by tying A to ground with a banana to banana
10. Make sure that the fault is open and the breaker is closed
11. Turn on the Circuit
12. Fault a single line to ground at 50% of the line using the fault box. Turn off if breaker did not open
13. Check that the zone 1 indicator light on the front panel display of the relay lights.
14. From the event report generated in the terminal window, record which element sent the trip signal and the time when the breaker tripped.
15. Record the time in cycles and seconds.
   *Note: the times are given in cycles*
16. Click on tools>events>get event files.
17. Select the log files you want to save
18. Click get event report
19. Save the file
20. Open file and view results
21. Repeat steps 8 through 20 for each fault type.

Relay Configuration for Time Over-current Protection:

Change the following settings with the AcSElerator:

22. Disable Mho phase and ground distance elements
   \[ E21P := N \]
   \[ E21MG := N \]
23. Enable Time Over-current element.
   a. *Time Over-current*

   \[ E51S := 1 \] Time Over-current element (N, 1-5)

   *Once in the Time Over-current settings of the relay configuration menu under the configuration tree, click Help-Settings Help for information regarding over-current relay settings such as operating quantity, pick-up, and over-current curve selection.

   For this example use:
   \[ E51S1O := 3I0L \] Operating Quantity (IA, IB, IC, IMAX, I1L, 3I2L, 3I0L)
   \[ E51P := \] O/C Pickup (0.25-16.00 = OFF, (0.05-3.2) x \( I_{nom} \))

   Using your calculated fault values choose a time-dial-setting that will yield a trip time of less than a half of a second for a single line to ground fault at 100% of the line and using the default O/C curve, \( U3 \).
   \[ E51S1TD := _____ \] Inv-Time O/C Time Dial (0.50-15.00)

   b. *Trip Logic*

   \[ TR = 51S1T \]
24. Send the settings to the relay. File>Send
25. Fault the lines for each type of fault and at 50% of the line. For each, record the trip time. Two log files should appear in the terminal window. The first is the log file generated when the fault occurred, the second is the log file generated when the breaker tripped. The trip time is the difference between the two.

Note: These times should be under 0.5s because a single-line-to-ground fault is the smallest fault current the system will see.

Note: At any point line quantities may be monitored via the relay’s front panel LCD or by choosing Tools-Meter and Control from the main menu. In the Meter and Control screen, phasors of the line quantities can be viewed as well as many other waveforms and other valuable information. Try it! See if the faulted phasors agree with your intuition.

III. SEL 311 Digital Relay
SEL 311 is a microprocessor based relay with multifunction characteristics. This unit can be programmed for Instantaneous Overcurrent, Time Overcurrent, Impedance, Over- and Under-voltage, and metering.

Equipment List
3 R-L-R modules
3 L-R modules
1 Resistance load

 Relay Communication Set-up
  3. Relay Parameters
  a. Open the AcSELerator and select communication parameters make
     sure that the following is selected:
     COM1 communications port

     | Bits per second | Data bits | Parity | Stop bits |
     |-----------------|-----------|--------|-----------|
     | 2400            | 8         | none   | 1         |

 Relay Parameters Set-up
  26. Open the AcSELerator Quickset and click on New Settings. Select
      the number of the relay that matches the relay in use. Press Status
      and use the other button to see the numbers after Z.

Figure 0-5: First Screen When Opening AcSelerator QuickSet

  27. On the PC screen enter the Part Number On the back of the relay
      there is a P/N code that you can follow.
28. Click on Group 1 then go to phase distance

29. Calculate the line impedance what the zone one impedance should be. (80% of line)

30. Then Go to Logic 1
Figure 0-8: Trip Settings set to Phase and Ground Zone 1 Detection

31. Fill in the correct Trip parameters of zone 1 ground and zone one phase

32. Go to output contacts and for out101 fill in the same trip parameters
Figure 0-9: Out105 Connected to the 3 Phase Circuit Breaker Trips when Trip is Alarmed

33. Go to Global then click on General

a. Set using Setting Editor
   i. Under General Global Setting:
      NFREQ (Nominal System Frequency) = 60Hz
      PHROT (System Phase Rotation) = ACB
      DATE-F (Date Format) = MDY

Current and Voltage Source Selection: Set ESS to N this allows the relay to get its currents and voltages from W and Y terminals respectively (on the back of the relay).

Leave everything else as is.

34. Save the file
35. Transferring the file: Select *File > Send* to transmit the settings to the relay.

36. Set up the circuit below

*Note: the circuit breaker can be powered with either 125V DC or 120V AC*

![Circuit Diagram for SEL 311 Digital Relay](image)

Figure 1: Circuit diagram for SEL 311 digital relay

37. Open a terminal window by clicking on the terminal button on the far right of the main terminal bar in AcSELerator.
38. Connect the Resistance Load for single line to ground by tying A to ground with a banana to banana
39. Make sure that the fault is open and the breaker is closed
40. Turn on the Circuit
41. Fault a single line to ground at 50% of the line using the fault box. Turn off is breaker did not open
42. Check that the zone 1 indicator light on the front panel display of the relay lights.
43. From the event report generated in the terminal window, record which element sent the trip signal and the time when the breaker tripped.
44. Note the times are given in cycles.
45. Record the time in cycles and seconds.
46. Alternatively, in the main AcSELerator window, click on tools>events>get event files. Click Select the log files you wish to save in the right hand column, click the get event report button. Save the .cev file. From the main AcSELerator window, select tools-view event files and choose the file you wish to view.

47. Repeat steps 38 through 46 for each fault type.
Note: At any point line quantities may be monitored via the relay’s front panel LCD or by choosing Tools-Meter and Control from the main menu. In the Meter and Control screen, phasors of the line quantities can be viewed as well as many other waveforms and other valuable information. Try it! See if the faulted phasors agree with your intuition.
APPENDIX B: Detecting Incorrect Input Settings for the AMS

While running tests using the AMS, it is very simple to accidentally input an incorrect number. An easy way to determine if an input is incorrect is to look at the data of events using the SEL 421. An event is created if a trip occurs or can be manually induced. There are many ways to manually induce an event, one way is to go to Tools→ Events→ Get Event Files. A new screen will pop up and on the right side of the screen a push the button saying Trigger Event. After the event is triggered, get the event by first refreshing the event history, selecting the right event and pressing Get Selected Event, as shown in Figure 3-12.

An example of finding an incorrect input is shown below. In the DG Setting 1, the voltage phase does not change and therefore the Voltage Phase Jump Detection should not detect islanding. In this case the phase B and C were switched for the first 8 cycles of islanding and can be clearly seen in the event file shown in Figure 0-12. A clear change in phase is observed when there should be none. Seeing this tells the tester that something is wrong and values need to be rechecked.
Figure 0-12: DG Setting 1 Voltage and Current when the Phase B and C Voltage are Switched for the First 8 Cycles of Islanding

Another way to see if there is an error is to prolong each state in the AMS and view the phase, voltage, and current readings using the SVP Configurator. If there is a huge discrepancy from the calculations, then there must be something wrong with either the AMS test case or the setting on how the SVP is reading the data.